Lenovo Legion Y530


When i realized i wanted a decent gaming rig, i did a bit of research and decided that i rather go for a notebook than for a new Desktop. And this model appeared to be rather good and affordable in good used condition. So i bought one, and in general its quite nice. But after a few Weeks the battery stopped working. Completely. It did not loose capacity or anything. The notebook just decided it wont use the battery. As it turned out, thats a known bug related to firmware either on the mainboard, the battery or both. Lenovo tried a while to fix it, then went completely silent about the issue. Its not covered by warrenty, even though the problem is the result of a buggy firmware. Replacing the mainboard costs more than the thing is worth, and replacing the battery may or may not help. And is quite expensive.
As i was rather sure that the problem is not exclusively in the battery, i got a bit sneaky. I bought a cheap third party battery from china, figuring that those would not have lenovo firmware and would not take a firmware upgrade. And guess what? The new battery is charged by the notebook and will power the notebook. The only thing not working is that the notebook can not be powred on without external power...
I rigged two 18650 Cells and a boost converter into a kind of kickstarter. It can not deliver enough power to actually power the notebook, but it can hold the 19V 2A the notebook draws initially when connected. At least it does so long enough to press the power button. After that it runs from battery, and it did not matter that the puny boost converter chickens out. Sooo, basically a kickstart :D

And now?


Meh. Its there. It kinda works. Right now its mostly used for couch potato purposes. Meh.

System

  • Lenovo Legion Y530, 2018 15.6" Gaming Workstation, ????g
    • UEFI Boot , BIOS Boot ? # not sure if legacy mode is supported at all
    • ACPI events , ACPI keys
    • S2R , S2D ? # S2R is pretty reliable, but sometimes Wifi is br0ken
    • power consumption 12W # With Prime but without D3, proprietary Nvidia drivers
  • Intel ???
    • Fan control # Rather quiet under moderate load
  • Intel Core i7-8750H (6 Cores, ???GHz, ??W TDP)
    • cpufreq # via pstates
    • turbo # up to ??GHz
  • Two DDR4-2933 slots # mine had 2*8
  • Intel UHD Graphics ???
  • Nvidia Geforce GTX 1050TI , Prime
    • Nouveau drivers ?
  • ? M.2 Slots # ? small (42mm), ? big (60mm)
    • PCI Express / NVMe
    • SATA ?
    • USB
  • ??? Gigabit Ethernet
  • ??? NVMe
  • 1 USB 3.? Type C Ports + DP
  • 3 USB 3.? Type A Ports + PowerShare ? # only one port provides PowerShare
  • Mini-DP ??? ?
  • Intel Wi-Fi ??? (802.11a/b/g/n/ac/ax)
    • Managed Mode ?
    • Bluetooth 5.1
  • Realtek ALC???
    • Headset connector
    • Speakers # Sound is ok
    • Microphone ?
  • 15.6" matte FHD IPS
    • Brightness control # very smooth
  • SD card reader
  • Webcam ??? # Below the screen. Bad angle.
  • Touchpad
  • Keyboard
  • Battery ??Wh # See apropriate chapter

Battery troubles

Path: 16.794, Handler: 1.012, Options: 5.479, Content: 0.08, Template: 0.029, Render: 0.225